Opened 13 years ago

Closed 13 years ago

#2015 closed enhancement (wontfix)

GoogleMap version

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone: 0.9
Component: Widgets Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

It would be great to get a function to set the version of the GoogleMaps? API. Current dojo version only supports version 2.0. But some functions of GoogleMaps? are only available in newer versions > 2.0! Thanks so far ...

Change History (2)

comment:1 Changed 13 years ago by alex

Milestone: 0.5
Owner: changed from bill to Tom Trenka

comment:2 Changed 13 years ago by Tom Trenka

Resolution: wontfix
Status: newclosed

According to the Google, current version is 2.67. There are two issues here: the first is that a function to set the version is impossible to do (Dojo would need that version long before onload). It might be addable as a djConfig variable, but knowing that Google changed the API between versions 1 and 2 is enough for me to close this bug--because the current widget is written against v.2.

Also, Google has shown that they are willing to close off old versions of the API at some point, making setting a version a temporary thing at best. If and when Google begins work on API v.3, we will look at the possibility of setting version numbers.

Note: See TracTickets for help on using tickets.