Opened 13 years ago

Closed 13 years ago

#2014 closed defect (worksforme)

GoogleMap won't work with current version 4.1

Reported by: guest Owned by: Tom Trenka
Priority: high Milestone: 0.9
Component: Widgets Version: 0.4.1rc1
Keywords: Cc:
Blocked By: Blocking:

Description

I didn't get an Id from the GoogleMap? widget with the current svn-code. With older versions, all worked fine:

<div dojoType="googlemap" id="mapTest" class="map2"></div>

var myMap = dojo.widget.byId('mapTest'); myMap.map.setCenter(new GLatLng(51.65956557, 8.230047225), 11);

Change History (5)

comment:1 Changed 13 years ago by alex

Milestone: 0.5
Owner: changed from bill to Tom Trenka

comment:2 Changed 13 years ago by alex

Priority: highnormal

comment:3 Changed 13 years ago by Tom Trenka

Resolution: worksforme
Status: newclosed

Tested this with the current Google Map test, and it worked just fine (looks like the point is somewhere in Germany?).

comment:4 Changed 13 years ago by guest

Resolution: worksforme
Status: closedreopened

I get the problem because I use my own packed version of dojo where I put GoogleMap? in my profile. Maybe thats because I get the error. If I add a dojo.require("dojo.widget.GoogleMap?"); to my code all works fine, but loading time is longer. So any idea???

comment:5 Changed 13 years ago by Tom Trenka

Resolution: worksforme
Status: reopenedclosed

Simple solution: don't put that widget in your profile. Both GoogleMap? and YahooMap? have specific requirements (in particular, the ability to write script tags via document.write) that make them impractical in a build.

Loading time will be longer but unfortunately that is a consequence of using Google Maps (their script is huge, last I checked it was pushing 200k compressed).

Note: See TracTickets for help on using tickets.