Opened 12 years ago

Closed 8 years ago

#1994 closed defect (invalid)

Tree: TreeBasicControllerV3.createAndEdit has limited functionality

Reported by: ornus Owned by: anonymous
Priority: high Milestone: future
Component: Dojox Version: 0.4.1rc1
Keywords: tree widget Cc: sol@…
Blocked By: Blocking:

Description (last modified by dylan)

*createAndEdit* fires *addChild* event twice. first when the node is created and then when node rename completes. in all other instances of when node is rename this doesn't happen. first this is an inconsistency is widget behavior. second when events fire too quickly one after the other it could lead to problems (because widgets that show additional information for the node can't update as quickly).

is it possible to provide consistent (create->rename) behavior?

Change History (5)

comment:1 Changed 12 years ago by ornus

actually it looks from the code comments that this behavior is by design. I simply created my own controller to provide me with functionality I'm looking for.

comment:2 Changed 12 years ago by bill

Component: WidgetsDojox
Milestone: 0.9
Summary: TreeBasicControllerV3.createAndEdit has limited functionalityTree: TreeBasicControllerV3.createAndEdit has limited functionality

Editing not supported in Dijit tree; moving to Dojox.

comment:3 Changed 11 years ago by dylan

Milestone: 1.2

comment:4 Changed 11 years ago by dylan

Description: modified (diff)
Milestone: 1.2future
Owner: changed from ilia to anonymous

comment:5 Changed 8 years ago by Adam Peller

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.