Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1984 closed defect (fixed)

repeatedly selecting options from ComboBox popupwidget causes errors (IE only)

Reported by: ialpert@… Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: ComboBox Cc:
Blocked By: Blocking:

Description

If i get repeatedly selecting differnt results from a the Combobox popup widget causes javascript errors in Internet Explorer. Tested against testswidget est_ComboBox.html

Change History (10)

comment:1 Changed 13 years ago by Izaak Alpert

I've tried to exhibit this behavior a second time cannot seem to -- I assume it's a pebkac issue. I'll append more as i get it...

I do get other different bizarre behaviour though:

  1. selecting repeatedly from any combo box on the page sometimes sets the pages scrollbar so that the input box for the combobox is at the top of the page
  2. I get object errors i'm not positive but i think this is caused by the

ComboBox?>>_onMouseOut:function(/*Event*/ evt) sometimes the relTarget.parentNode is null.

  1. Sometimes i get "Could not complete the operation do to error 800a025e" which i've only seen referenced here: http://www.supermemo.com/help/faq/errors.htm#15032-6351 . Not sure what that's about

Putting a try/catch block and debugShallow on the exception in selectOption function yealds this: DEBUG: ------------------------------------------------------------ DEBUG: Object: [object Error] DEBUG: description: Could not complete the operation due to error 800a025e. DEBUG: message: Could not complete the operation due to error 800a025e. DEBUG: name: Error DEBUG: number: -2146827682 DEBUG: ------------------------------------------------------------

comment:2 Changed 13 years ago by Izaak Alpert

Note: in all cases i'm using the arrow Image to get to open the popup

comment:3 Changed 13 years ago by Izaak Alpert

Ok it seems all previous errors were caused by the 800a025e error which occurs inside the selectOption method (sorry i haven't been more deterministic).

comment:4 Changed 13 years ago by Izaak Alpert

If i continously select items from the popupWidget in the comboBox i get this error (note this only seems to happen if i select multiple times from differnt comboboxs on the same page: I've narrowed this down to this method: _hideResultList: function(){

try{

this.popupWidget.close();

}catch(e){dojo.debugShallow(e);}

},

Yields: DEBUG: ------------------------------------------------------------ DEBUG: Object: [object Error] DEBUG: description: Could not complete the operation due to error 800a025e. DEBUG: message: Could not complete the operation due to error 800a025e. DEBUG: name: Error DEBUG: number: -2146827682 DEBUG: ------------------------------------------------------------

comment:5 Changed 13 years ago by moose4lord@…

I also saw some odd behavior with combo boxes and IE 6.0. Not sure if it's related to this ticket, but when I select the last item in a select box, then select any other item in the box, I get the JavaScript? error "Unexpected call to method or property access." Tested with test_Select.html and IE 6.0. Firefox seems to work fine.

Keith

comment:6 Changed 13 years ago by bill

Milestone: 0.4.1

This reproduces for me, although you have to select popup values 10 or 20 times. Still, it's a bad bug (especially since it happen's on IE, the world's most used browser)

comment:7 Changed 13 years ago by Jonathan Bond-Caron

This fix seems to solve it for me:

http://trac.dojotoolkit.org/ticket/2070

The error occurs on Firefox as well & other browsers, only IE blocks

comment:8 Changed 13 years ago by bill

Status: newassigned

That doesn't fix it for me. I've traced the problem down to code in popupContainer (used for the drop down list) that calls moveBookmark to restore selected text. It's related to the text (or part of the text) in the Combobox's <input> field being highlighted. For some reason occasionally that moveBookmark() call gets an internal error. I'll squelch the error.

comment:9 Changed 13 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [6785]) Fixes #1984.

For some reason, occasionally when the text (or part of the text) in the Combobox's <input> field is highlighted, the moveBookmark() call gets an internal error on IE. I squelched the error. (moveBookmark() is used to restore which text on the screen is currently selected)

comment:10 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.