Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1982 closed defect (duplicate)

on IE, problems resizing ModalFloatingPane

Reported by: yh_mailinglist@… Owned by: liucougar
Priority: high Milestone:
Component: General Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hello dojo team,

Same description as ticket 1981. On IE, the first time the box is opened, if you try to reduce the size, it is ok but when you try to increase the size, it does not work unless you move the mouse veeeeery sloooowly.

also, I've noticed that the floating pane appears as if it was selected (e.g. text caption is highlighted), which does not look very nice.

Thanks

problem on IE 6/windows XP. on FF 1.5 it works ok

(11.22.2006 nightly build used, widget build)

Yann

Attachments (1)

modalfloatingpanepb.html (1.4 KB) - added by yh_mailinglist@… 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by yh_mailinglist@…

Attachment: modalfloatingpanepb.html added

comment:1 Changed 13 years ago by Jonathan Bond-Caron

This is a duplicate of #1898,

I've documentated the problem maybe more clearly... I think dojo will need a major rework for this fix.

It's basically a nested iframes issue. Since an iframe (in IE) occupies the whole document (modal background), and the floating pane itself is an iframe.

Other widgets (the resizer, floating pane) only connect to one background dojo.body()

There needs maybe another function:

dojo.bconnect("onclick", this, "dosomething");

where the dojo bconnect function will connect to the background - all 'visible' iframes or dojo.body(). It's a bit more complicated since each iframe window has their own coordinates.

comment:2 Changed 13 years ago by bill

Owner: changed from anonymous to liucougar

comment:3 Changed 13 years ago by liucougar

Resolution: duplicate
Status: newclosed

dup of #1898

comment:4 Changed 13 years ago by liucougar

Milestone: 0.4.1

comment:5 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.