Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1966 closed defect (fixed)

toolbar shortcuts don't work

Reported by: jowenn@… Owned by: liucougar
Priority: high Milestone:
Component: Editor Version: 0.4.1rc1
Keywords: editor2 shortcuts Cc:
Blocked By: Blocking:

Description

In 0.4.0 it was possible to assign CTRL+R as a shortcut and it did work, as long as the editor has been focused. In todays svn it doesn't work anymore.

The custom action gets invoked, but after that firefox reloads the page

Change History (4)

comment:1 Changed 13 years ago by jowenn@…

This behaviour was caused by an api change, which threw an exception within the shortcut handler.

I think for easier debugging the block in Richtext.js for invoking the handler should be something like:

if (this._keyHandlers[e.key]) {

dojo.debug("char:", e.key); var handlers = this._keyHandlers[e.key], i = 0, handler; while (handler = handlers[i++]) {

if (modifiers == handler.modifiers) {

try {

handler.handler.call(this);

} catch (ex) {

dojo.debug("Exception while invoking richtext keyhandler:"+ex);

}

e.preventDefault(); break;

}

}

}

comment:2 Changed 13 years ago by liucougar

Milestone: 0.4.1

comment:3 Changed 13 years ago by liucougar

Resolution: fixed
Status: newclosed

(In [6687]) fixes #1966: call preventDefault first before calling the actual shortcut handler so that even if error occurs in the handler, the default behavior is prevented

comment:4 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.