Opened 13 years ago

Closed 12 years ago

#1946 closed defect (wontfix)

Dojo Demos: JSON-RPC Client broken in various ways (buttons broken, etc)

Reported by: amit@… Owned by: anonymous
Priority: high Milestone: 0.9
Component: General Version: 0.4.1rc1
Keywords: Cc:
Blocked By: Blocking:

Description

I got a clean build here: http://download.dojotoolkit.org/release-0.4.1rc1/dojo-0.4.1rc1-core.tar.gz

A clean (unmodified) version of the demos is here: http://dojo.mixie.org/dojo-0.4.1rc1-core/demos/demoEngine.html

  1. Click on the link above.
  1. Click on RPC
  1. Click on '-> View Demo'

This brings up the JSON-RPC Client in Dojo 0.4.1 Release Candidate 1.

The following problems are observed:

1. In Firefox 2.0 (ummodified) the "buttons" don't appear as buttons (They appear as buttons in Firefox 1.0.7, IE 6.0 & IE 7.0).

Firefox 2.0 has the following message in the debug trace (the other browsers that work don't have this message in the debug trace):

"DEBUG: dojo.widget.Parse: error: [TypeError: cStyle has no properties, file: http://dojo.mixie.org/dojo-0.4.1rc1-core/dojo.js, line: 163]"

2. When the buttons do appear, the RPC don't work due to a missing 'File.php'.

The following appears in the debug log, when pressing the first button:

DEBUG: JsonService?: JSON-RPC Request: {"params":blah?,"method":"myecho","id":1}

DEBUG: [SyntaxError: Syntax error]

DEBUG: main(File.php): failed to open stream: No such file or directory in /home/dojo/public_html/dojo-0.4.1rc1-core/tests/rpc/test_JsonRPCMediator.php

3. Minor issue, all versions have the following in the debug log:

DEBUG: DEPRECATED: dojo.debug.Firebug is slated for removal in 0.5; use dojo.debug.console instead. 0.5

DEBUG: DEPRECATED: dojo.rpc.Deferred replaced by dojo.Deferred -- will be removed in version: 0.6

Change History (4)

comment:1 Changed 13 years ago by amit@…

More testing . . .

4. It failed to load the demo first time when used via https for Firefox 2.0. You can try the same files via https through the following link: https://gauguin.hmdnsgroup.com/~dojo/dojo-0.4.1rc1-core/demos/demoEngine.html

It worked in Firefox 1.0.7, IE 6.0 (although it complained the page contained both secure & non-secure items), and IE 7.0

It then worked the second time when using Firefox 2.0

Also, The buttons now started to appear in Firefox 2.0 (unlike before when they didn't). So this (the buttons not appearing) is an intermittent bug?

comment:2 Changed 13 years ago by amit@…

The demos very very intemittingly sometimes don't bring up everything in FF 2.0 (to it is not related to https, but happens with http also, sometimes)

It almost appears that some load of source is silently failing.

Its very hard to reproduce unfortunatly :(

comment:3 Changed 13 years ago by dylan

Milestone: 0.9

comment:4 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

demoengine stuff isn't getting ported to 0.9

Note: See TracTickets for help on using tickets.