Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1928 closed defect (fixed)

tree leaks memory with context menu attached in IE

Reported by: ornus Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: tree menu Cc: sol@…
Blocked By: Blocking:

Description

the leak is about 200K. I'm not sure if it's a menu bug or tree bug. the leak present only if context menu is bound to the tree. if context menu widget is declared, but not bound to the tree, there's no leak.

I suspect the problem is with menu binding to another widget, but I could be wrong.

Change History (6)

comment:1 Changed 13 years ago by ornus

actually in a different setup the leak is about 1.5MB, so it can be quite severe. I traced it to menu <-> tree connection as well.

comment:2 Changed 13 years ago by ornus

the problem is actually not in the menu, but in the disconnect. when menu unbinds from the tree it calls dojo.event.kwDisconnect. this is where the leak occurs. if I comment out this single call to disconnect there's no leak.

comment:3 Changed 13 years ago by Adam Peller

There are removeChild/replaceChild calls in tree (see #1927) though I wasn't planning on addressing this for 0.4.1 given the timing. Maybe we need to consider it. I don't know if this is the leak you're seeing or not.

comment:4 Changed 13 years ago by ornus

I don't think so. this is specificall related to the menu disconnecting from the tree

comment:5 Changed 13 years ago by alex

Resolution: fixed
Status: newclosed

the kwDisconnect() leak was fixed in r6628

comment:6 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.