Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19044 closed defect (fixed)

Support dojo-webpack-plugin

Reported by: dylan Owned by: dylan
Priority: high Milestone: 1.10.9
Component: Loader Version: 1.12.2
Keywords: Cc:
Blocked By: Blocking:

Description

https://github.com/dojo/dojo/pull/266

The function fixupUrl() is currently declared within a has('dojo-inject-api') conditional, but the function is called by req.toUrl(), which is declared outside of any has conditional. This means that req.toUrl() cannot call fixupUrl() if the loader was built with dojo-inject-api=0.

This change is needed so that dojo-webpack-plugin can build the embedded loader with dojo-inject-api =0, thereby reducing the size of the embedded loader within the packed assets by eliminating unneeded code for loading modules, and still support calling require.toUrl() by the application.

Change History (5)

comment:1 Changed 2 years ago by dylans <dylan@…>

Resolution: fixed
Status: newclosed

In b26cadf/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:2 Changed 2 years ago by dylans <dylan@…>

In d00ca0cd/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 2 years ago by dylans <dylan@…>

In 1785c96/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 2 years ago by dylans <dylan@…>

In 6c6d299d/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 2 years ago by dylan

Milestone: tbd1.10.9
Note: See TracTickets for help on using tickets.