Opened 2 years ago

Closed 22 months ago

Last modified 22 months ago

#19033 closed defect (fixed)

dojox IndicatorElement is not working properly when has('dojo-bidi') is true.

Reported by: bmaier Owned by: dylans <dylan@…>
Priority: high Milestone: 1.9.12
Component: Charting Version: 1.12.2
Keywords: Cc:
Blocked By: Blocking:

Description

Thiscode, inverts the indicator element whenever has('dojo-bidi') is true, but when the chart is not RTL it should not. When the chart is RTl, the chart is already being inverted so this flips it back to being incorrect. The latter behavior can be seen in one of the test pages, and if you set has('dojo-bidi') to true on the normal mouse indicator test page you can see the issue there as well.

This code was originally introduced as a fix for RTL support, so I'm a little concerned that it fixed a scenario I'm not seeing. But as far as I can tell, it seems to break it in either case.

Attachments (1)

twoIndicators.png (52.2 KB) - added by bmaier 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by bmaier

Attachment: twoIndicators.png added

comment:1 Changed 2 years ago by bmaier

The code was originally intended to fix an issue where two indicators appear on a chart, but as can be seen in the screenshot that issue can still be reproduced in some circumstances with the fix, which also causes this issue.

comment:2 Changed 2 years ago by bmaier

comment:3 Changed 22 months ago by dylans <dylan@…>

Owner: set to dylans <dylan@…>
Resolution: fixed
Status: newclosed

In 1d4bf81/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 22 months ago by dylans <dylan@…>

In dbf7c2c/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 22 months ago by dylans <dylan@…>

In 5aa62cd/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 22 months ago by dylans <dylan@…>

In 925aada/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 22 months ago by dylan

Milestone: tbd1.9.12
Priority: undecidedhigh
Note: See TracTickets for help on using tickets.