Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1898 closed defect (fixed)

TestModalFloatingPane.html IE 6 -- Problem with Iframe

Reported by: jbondc@… Owned by: liucougar
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

Point Internet Explorer 6.0 to http://archive.dojotoolkit.org/nightly/tests/widget/test_ModalFloatingPane.html

Try to a) Move the floating pane quickly b) Resize the floating pane quickly

The floating pane itself works fine but mixing it with the modal widget does not go well. The events do not fire outside of the iframe (floating pane).

It's likely something to do with:

show: function(){

dojo.widget.ModalFloatingPane?.superclass.show.apply(this, arguments); this.showModalDialog(); place the background div under this modal pane this.shared.bg.style.zIndex = this.domNode.style.zIndex-1;

},

show: function(){

dojo.widget.ModalFloatingPane?.superclass.show.apply(this, arguments); this.showModalDialog(); uncommenting here, it almost works place the background div under this modal pane this.shared.bg.style.zIndex = this.domNode.style.zIndex-1;

},

The fix is likely in Dialog.js

this.shared.bgIframe = new dojo.html.BackgroundIframe?(this.shared.bg); ?

Or there's a need for a new show & hide function...

jon

Change History (8)

comment:1 Changed 13 years ago by bill

Milestone: 0.5

Yeah, it reproduces for me.

comment:2 Changed 13 years ago by liucougar

Milestone: 0.50.4.1
Owner: changed from bill to liucougar

comment:3 Changed 13 years ago by liucougar

Resolution: fixed
Status: newclosed

(In [6690]) fixes #1898: the underlay div is now above iframe

comment:4 Changed 13 years ago by Jonathan Bond-Caron

Resolution: fixed
Status: closedreopened

The fix broke it for me in IE 6.0... and in firefox. There's also the drag & drop issue...

And thats part of a bigger problem.. please have a look at: http://qooxdoo.org/about/release_notes

Their iframe manager solves the drag and drop problem over iframes... Unless I'm missing something, dojo should have something similar.

There's lots of other cases that can break right now and here's a quick example:

<div dojoType="SplitContainer?" orientation="horizontal" sizerWidth="5" style="width: 400px; height: 100px;">

<div dojoType="ContentPane?" sizeMin="20" sizeShare="50">

<iframe width="100" height="100"></iframe>

</div> <div dojoType="ContentPane?" sizeMin="50" sizeShare="50">

<iframe width="100" height="100"></iframe>

</div>

</div>

jon

comment:5 Changed 13 years ago by liucougar

what breaks?

in your sample, I can not see any ModalFloatingPane? widgets

comment:6 Changed 13 years ago by Jonathan Bond-Caron

Forgot to clear my cache for IE, your right it fixes it :)

In firefox, I get: this.shared.bgIframe.iframe has no properties

The problem is with:

this.shared.bgIframe = new dojo.html.BackgroundIframe?(); with(this.shared.bgIframe.iframe.style){

new dojo.html.BackgroundIframe?() only renders an iframe in IE: dojo.html.BackgroundIframe? = function(/* HTMLElement */node) {

if(dojo.render.html.ie55
dojo.render.html.ie60) {

other then that fix looks good :) forget my sample... i'll open other tickets for iframe problems..

comment:7 Changed 13 years ago by liucougar

Resolution: fixed
Status: reopenedclosed

(In [6692]) fixed Dialog broken in browsers other than IE 6, refs #1898

comment:8 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.