Opened 3 years ago

Closed 3 years ago

#18969 closed defect (invalid)

Dojo.require failing for dnd.source

Reported by: rhang Owned by:
Priority: undecided Milestone: tbd
Component: DnD Version: 1.12.1
Keywords: Cc:
Blocked By: Blocking:

Description

Error: Could not load 'dojo.dnd.Source'; last tried './dnd/Source.js'

at Object.dojo._loadModule.dojo.require

I noticed this yesterday! The code in our code base which seems to trigger this is:

Dojo required dependencies dojo.require("dojo.dnd.Source");

Change History (3)

comment:1 Changed 3 years ago by dylan

Status: newpending

The existing tests we have in place are not breaking, so we'll need more information than this to help track down your issue:

  • What version of Dojo are you using?
  • Which browser(s) are you seeing this error?
  • What else are you doing in your application (what's the path to Dojo, your configuration, etc.)?
  • Verify that dojo/dnd/Source.js exists in your source tree
  • Can you reproduce with an example using JSFiddle?
  • Is there a reason you are using pre-AMD syntax?

comment:2 Changed 3 years ago by dylan

Component: GeneralDnD

comment:3 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.