Opened 2 years ago

Closed 2 years ago

#18962 closed defect (invalid)

request/xhr and request/node and progress notifications

Reported by: Martin Marko Owned by:
Priority: undecided Milestone: 1.13
Component: Core Version: 1.12.1
Keywords: Cc:
Blocked By: Blocking:

Description

progress notification is not geting data, as documented

https://dojotoolkit.org/reference-guide/1.9/dojo/request.html

Progress data will be given to the progress handler if it is provided and if the platform supports progress events (any browser supporting XHR2 or node.js).

in xhr implementation, progress callback receives response and chunk has to be parsed as delta from response.xhr.responseText in node there is notificaton missing (only on('socket') is repoted as promise progress.

Any chanve for uniform integrace with chunks of data to be sent as callback parameters and implemented in both components ?

This is essencial for JSON Streaming and other Streaming styles of requests. Thanx a lot.

Change History (2)

comment:1 Changed 2 years ago by dylan

Milestone: tbd1.13
Status: newpending

Should this supersede #18959 which you opened two days ago?

Also, I still think this is a duplicate of #18922 probably...

comment:2 Changed 2 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.