Opened 3 years ago

Closed 3 years ago

#18914 closed defect (invalid)

The Grid Plot fails to render the axes correctly when chart.movePlotToBack("gridplot"); is used for a negative axis values.

Reported by: hanif.kukkalli Owned by: dylan
Priority: undecided Milestone: 1.12
Component: Dojox Version: 1.11.2
Keywords: Cc:
Blocked By: Blocking:

Description

When I tried to move the grid plot behind the other plots, the rendering of the axes values fails.

The negative y-axis is rendered on the x-axis and the y-axis starts at 0.

The scenario: The chart has values for x-axis as dates and for y-axis ranging from -50 to 50.

When the grid plot is moved to back of the other series plot(for example column), it fails to render the axis correctly. The y-axis displays range from 0 to 50 and x-axis displays range -40 to 0 and then the dates.

Attachments (1)

error_ploting_axis.png (93.7 KB) - added by hanif.kukkalli 3 years ago.
error image

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by hanif.kukkalli

Attachment: error_ploting_axis.png added

error image

comment:1 Changed 3 years ago by hanif.kukkalli

The issue is not in Dojo, it was in the chart axes configuration. This ticket can be closed.

comment:2 Changed 3 years ago by hanif.kukkalli

This Ticket can be closed. It was chart configuration issue and not a bug from Dojo. Apologies for consuming any of your time.

comment:3 Changed 3 years ago by dylan

Milestone: tbd1.12
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.