Opened 3 years ago

Closed 3 years ago

#18873 closed defect (invalid)

loading dojo.js with relative path ../dojo/dojo.js

Reported by: aploese Owned by:
Priority: undecided Milestone: 1.12
Component: General Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

having this test.ntml in a sibling directory of dojo and dijit: <!DOCTYPE html> <html>

<head>

<title>Test</title> <meta charset="utf-8"></meta> <script data-dojo-config="async: 1" src="../dojo/dojo.js"></script>

<script>

require(["dijit/form/Button", "dojo/domReady!"], function (Button) {

alert("AMD Button loaded "); var button = new Button({title: "Test"}, "contenet");

});

</script>

</head> <body>

<div id="contenet"></div>

</body>

</html> Will not show the alert - it just fails silently... moving test.html up one directory, and change the srcipt tags src to dojo/dojo.js, works like expected. It seems that dojo/text or dojo/i18n getting confused by something. I have testet this with other files too.

Arne

Attachments (1)

test_1.html (524 bytes) - added by aploese 3 years ago.
AMD not loading Button

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by aploese

Attachment: test_1.html added

AMD not loading Button

comment:1 Changed 3 years ago by dylan

Milestone: tbd1.12
Status: newpending

I'm not able to reproduce this error. Is there something else within your app that is changing one of the ways in which modules or paths are calculated?

comment:2 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.