Opened 4 years ago

Closed 3 years ago

#18839 closed defect (invalid)

dijit/place.around() calculates position of an "around" Node incorrectly when this node is inside of fullscreened div

Reported by: 39dotyt Owned by: bill
Priority: undecided Milestone: 1.11.3
Component: Dijit Version: 1.11.1
Keywords: Cc:
Blocked By: Blocking:

Description

The bug is within those lines: https://github.com/dojo/dijit/blob/master/place.js#L285-L308

Breaking loop when we meeting a fullscreened parent should fix issue.

Change History (6)

comment:2 Changed 4 years ago by bill

Hmm, I tried dijit/tests/place.html in full screen mode and it seemed to work. Do you have a test case that fails?

comment:3 Changed 3 years ago by dylan

Milestone: tbd1.11.3

comment:4 Changed 3 years ago by Michael J Van Sickle

The test case provided in the PR no longer appears valid and we have not be able to independently reproduce the issue. Can you please provide another example of the failure so that we can validate the the PR resolves the issue?

comment:5 Changed 3 years ago by Michael J Van Sickle

Status: newpending

comment:6 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.