Opened 3 years ago

Closed 3 years ago

#18837 closed defect (invalid)

Unable to change font size in editor (IE 11)

Reported by: enterlne Owned by:
Priority: undecided Milestone: 1.12
Component: Editor Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

If some text is selected, and then the font size dropdown is used to change the font size, the font size remains the same and the focus is moved to the top of the editor.

I reproduced here: http://jaredj.dojotoolkit.org/editor_dojo15/

  1. Type some text in the editor
  2. Select the text
  3. Click the font size dropdown and select an option

This seems to be a problem only in IE11. I could not reproduce the problem in IE9, Firefox, or Chrome.

Change History (7)

comment:1 Changed 3 years ago by bill

Resolution: worksforme
Status: newclosed

Probably Jared has an old version of the editor. I tried on http://download.dojotoolkit.org/release-1.11.0/dojo-release-1.11.0/dijit/tests/editor/test_Editor.html (on IE11) and it worked for me.

comment:2 Changed 3 years ago by enterlne

I believe this problem is specific to having the editor in either a dialog or within an iframe. I am using 10.4.1 and I can reproduce the problem when the editor is in a dialog, but when it is on the main page it works fine. Do you have any test page for the latest version where the editor is on a dialog or in iframe?

comment:3 Changed 3 years ago by enterlne

Can I add additional information to closed defects or do I need to open another defect?

comment:4 Changed 3 years ago by dylan

Resolution: worksforme
Status: closedreopened

comment:5 Changed 3 years ago by dylan

Milestone: tbd1.12

comment:6 Changed 3 years ago by bill

Status: reopenedpending

Hmm, you first mentioned http://jaredj.dojotoolkit.org/editor_dojo15/, which is neither in a dialog nor an iframe. Try making a test case showing the failure and attach it with the "attach file" button. It should be a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

comment:7 Changed 3 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.