Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#18828 closed defect (fixed)

[regression] "npm install" broken

Reported by: bill Owned by: dylan
Priority: blocker Milestone: 1.11.2
Component: Core Version: 1.11.1
Keywords: Cc:
Blocked By: Blocking:

Description

Starting with 7f24d9a282d6ab1d222e17fec6f32394aef947f2, npm install is broken. (I'm running it because tests/README.md says I need to run it to run the tests.)

This is the output from that revision. The output on master is slightly different (looking for 1.12), but basically the same.

$ npm install
npm ERR! Darwin 14.5.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! node v4.2.6
npm ERR! npm  v3.7.1

npm ERR! No compatible version found: dojo@1.11.0-pre
npm ERR! Valid install targets:
npm ERR! 2.0.0-alpha4, 2.0.0-alpha3, 2.0.0-alpha2, 2.0.0-alpha1, 2.0.0-alpha.7, 2.0.0-alpha.6, 2.0.0-alpha.5, 1.11.1, 1.11.0, 1.11.0-rc5, 1.11.0-rc4, 1.11.0-rc3, 1.11.0-rc1, 1.10.5, 1.10.4, 1.10.3, 1.10.2, 1.10.1, 1.10.0, 1.9.8, 1.9.7, 1.9.6, 1.9.5, 1.9.4, 1.9.3, 1.9.2, 1.9.1
npm ERR! 
npm ERR! 
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /ibm-js/dojo/npm-debug.log

Change History (4)

comment:1 Changed 3 years ago by dylan

Milestone: tbd1.11.2
Priority: undecidedblocker

Ok, so I think the issue is probably that I made the devDependencies rely on the latest Dojo code, rather than the most recent stable release.

comment:2 Changed 3 years ago by Dylan Schiemann <dylan@…>

Resolution: fixed
Status: newclosed

In 3b0570c/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 3 years ago by Dylan Schiemann <dylan@…>

In 6094711/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 2 years ago by adros

Now is the dependency also pointing to non published version (1.13.0-pre, commit a1e2d9dd54c).

Note: See TracTickets for help on using tickets.