Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18818 closed defect (fixed)

[regression] dojo.locale broken on Android

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.10.6
Component: Core Version: 1.10.5
Keywords: Cc:
Blocked By: Blocking:

Description

As per the change in #18722, dojo.locale doesn't get set correctly on Android anymore.

Specifically, delite/tests/functional/DojoParser.html is failing to show dijit/CalendarLite and the root cause is that in config.js:

var language = navigator.languages ? navigator.languages[0] : (navigator.language || navigator.userLanguage);

navigator.languages[] is an empty array rather than null or undefined.

From a quick read of https://bugs.chromium.org/p/chromium/issues/detail?id=570349 it looks like this is intended behavior in Android and thus the bug is in dojo.

Note that dijit/tests/CalendarLite.html loads correctly because it defines the locale explicitly.

Change History (5)

comment:1 Changed 4 years ago by bill

Milestone: tbd1.10.6
Owner: set to bill
Status: newassigned
Version: 1.11.01.10.5

comment:2 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 48bd17d/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 4 years ago by Bill Keese <bill@…>

In 5db6bd6/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 4 years ago by Dasa Paddock

I think this still needs to be cherry picked to the 1.11 branch: https://github.com/dojo/dojo/blob/1.11/_base/config.js#L176

comment:5 Changed 4 years ago by Dylan Schiemann <dylan@…>

In 3594395/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.