Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18757 closed defect (fixed)

JAWS exits forms mode after pressing Enter to create a new line

Reported by: Herman Lo Owned by: bill
Priority: undecided Milestone: 1.10.5
Component: Editor Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Browser version: Firefox 38 ESR, 42.0 JAWS version: 16.0.4663 (Oct 2015 build) Dojo version: IDT 1.10.4-20150917-IBM RPT ruleset: CI162 v5.2 Plan DCP, 01 August 2015 or later

If you hit the Enter key when inside the dijit.Editor (to create a new line) , the JAWS screen reader will exit forms mode. You need to manually activate forms mode (hit Enter again). If your editing multiple lines in the dojo editor, you'll need to repeatedly re-enter forms mode.

The issue is reproducible on Firefox only (IE11 works fine). I've been able to reproduce the issue with both 1.10.4 and the public nightly (http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/editor/test_Editor.html).

if no fix from JAWS is forthcoming, then a workaround may be required for the dojo editor (i.e. change the contenteditable div role="textbox" and set aria-multiline="true"). However, this would result in a regression of #18731 ( setting role=main on Editor's iframe's <body> violates ARIA spec ) since the editor would be missing the "main" role. A more thorough solution may be required instead.

Change History (3)

comment:1 Changed 4 years ago by bill

Milestone: tbd1.10.5
Owner: set to bill
Status: newassigned

comment:2 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 006f679d7bb2562dc29b0d5ccb5e7440b79211fa/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 4 years ago by Bill Keese <bill@…>

In 052a273935de20d345f05e7d344121325d381cce/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.