Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#18752 closed defect (fixed)

dojox/mobile/Slider becomes unusable in ScrollablePane with same direction

Reported by: fabrizio.cucci Owned by: Patrick Ruzand
Priority: low Milestone: 1.10.7
Component: DojoX Mobile Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

I was building a custom widget containing a horizontal dojox/mobile/Slider placed in a horizontal dojox/mobile/ScrollablePane.

When I tried to move the slider handle I discovered something wonderful: not only it moves but the whole custom widget moves too! :)

I think that the proper behavior would be to not propagate the drag event when it happens on the "TouchBox?" and the "Handle" elements of the slider.

Adding:

e.stopPropagation();

as first line of the "beginDrag" function here:

https://github.com/dojo/dojox/blob/1.10/mobile/Slider.js

seems to work fine but I don't know if it might have unwanted side effects.

Thanks, Fabrizio

Change History (11)

comment:1 Changed 4 years ago by fabrizio.cucci

comment:2 Changed 4 years ago by Patrick Ruzand

hi, do you reproduce on master too ? (and if you have a simple reproducible sample ready (jsfiddle, gist, etc), would be even greater )

comment:3 Changed 4 years ago by dylan

Milestone: tbd1.11

comment:4 Changed 4 years ago by dylan

Priority: undecidedlow

comment:5 Changed 4 years ago by dylan

Milestone: 1.111.12

Ok, after massive triage, ended up with about 80 tickets for 1.11 and 400 or so for 1.12. That's a bit unrealistic, so first I changed all 1.12 to 1.13 (with the plan to move some forward to the new 1.12. Now, I'm moving some of the 1.11 tickets that are less likely to get done this month without help to 1.11. Feel free to help out in January if you want to see this ticket land in 1.11.

comment:6 Changed 3 years ago by dylan

Milestone: 1.121.13

Ticket planning... move current 1.12 tickets out to 1.13 that likely won't get fixed in 1.12.

comment:7 Changed 3 years ago by dylan

Milestone: 1.131.12

Moving back to 1.12 since this one has a PR that looks easy to accept.

comment:8 Changed 3 years ago by Michael Van Sickle <mvansickle@…>

Resolution: fixed
Status: newclosed

In e813541/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 3 years ago by Michael Van Sickle <mvansickle@…>

In 75ed78a/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 3 years ago by Michael Van Sickle <mvansickle@…>

In 76581994/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 3 years ago by Michael J Van Sickle

Milestone: 1.121.10.7
Note: See TracTickets for help on using tickets.