Opened 4 years ago

Closed 4 years ago

#18740 closed defect (invalid)

dijit.form.Button

Reported by: aleung Owned by: aleung
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

I try to create an icon button without border. Declarative definition: <button data-dojo-type="dijit/form/Button" data-dojo-props="iconClass:'downarrowIcon', showLabel: false" style="border-style:none" type="button" id="test" onClick="Test();"> Test </button>

The button instantiated as <span class="dijit dijitReset dijitInline dijitButton" role="presentation" style="border-style: none;" widgetid="test"> <span class="dijitReset dijitInline dijitButtonNode noborder" role="presentation" data-dojo-attach-event="ondijitclick:onClick"> ...

The border of the child span may be cause by it having the attribute 'role="presentation".' To eliminate the border I uses $("span[widgetid=test] > span[role=presentation]").addClass("noborder"); in dojo/ready.

The attribute is hardcoded in dijit/form/Button.js

cache:{"url:dijit/form/templates/Button.html":"<span class=\"dijit dijitReset dijitInline\" role=\"presentation\"\n\t><span class=\"dijitReset dijitInline dijitButtonNode\"\n\t\tdata-dojo-attach-event=\"ondijitclick:onClick\" role=\"presentation\"\n\t\t> ...

Change History (2)

comment:1 Changed 4 years ago by bill

Owner: set to aleung
Status: newpending

Do you think you seeing a bug? If so, list the expected behavior vs. the actual behavior you are seeing (and how they are different).

comment:2 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.