Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18726 closed defect (fixed)

[regression] scrollIntoView() broken for IE8 quirks RTL

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.7.9
Component: Core Version: 1.7.7
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

The changes from https://github.com/dojo/dojo/commit/a832214a342b6e03ad4a9b1669fae71c7938c44b broke scrollIntoView() on IE8 for quirks RTL, and then masked the error by inadvertently disabling those tests on IE8.

The mistake was because Mark was thinking the has("trident") is just for IE11+, but it's actually truthy for IE8 - IE11.

Change History (5)

comment:1 Changed 4 years ago by bill

Description: modified (diff)

comment:2 Changed 4 years ago by bill

Description: modified (diff)
Milestone: tbd1.7.9
Owner: set to bill
Status: newassigned
Summary: scrollIntoView() suspicious code for IE8[regression] scrollIntoView() broken for IE8 quirks and loose mode
Version: 1.10.41.7.7

comment:3 Changed 4 years ago by bill

Description: modified (diff)
Summary: [regression] scrollIntoView() broken for IE8 quirks and loose mode[regression] scrollIntoView() broken for IE8 quirks RTL

comment:4 Changed 4 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in 9362c6e8674471e9ea8666924c623fd95606e531, 6ddef724689b5b81af979b96632fed6029324709, 4ed9eb48c0c41dba64295e3f078c480f740b8b0a, 033f82428fd482154d1ece3d41f05311c7a77559, 15e3d45ed3f66c8e06dd43649628b09ed6e9e40a.

comment:5 Changed 4 years ago by bill

Type: taskdefect
Note: See TracTickets for help on using tickets.