Opened 4 years ago

Closed 4 years ago

#18711 closed defect (invalid)

When content is updated or destroy in a TooltipDialog, chrome sends a blur with no event handle.

Reported by: lcdaniel Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

If you try to update or destroy the content of a TooltipDialog?, chrome sends a blur with no event handle. We have tried to overwrite the default _onBlur and onBlur functions of this widget and use e.preventDefault() with no luck since their is no handle.

You can see this in action in the following jsfiddle example: http://jsfiddle.net/nw9tU/493/

Change History (2)

comment:1 Changed 4 years ago by lcdaniel

  • there is no handle.
Last edited 4 years ago by lcdaniel (previous) (diff)

comment:2 Changed 4 years ago by bill

Resolution: invalid
Status: newclosed

Yes, that's expected behavior, because the button (i.e. the <input>) inside the dropdown has focus, and you are destroying it.

Also, _onBlur() and onBlur() aren't supposed to get an event object as their parameter.

I suggest you stop overwriting the node that has focus. Maybe you can move focus back to the DropDownButton? that opened the TooltipDialog?. Or just change part of the content of the TooltipDialog?, but not the focused button.

Also, I'm not sure TooltipDialog? can handle changing the content while open (even if you aren't changing the focused node). It might change size and then need to be repositioned (or resized), and I'm not sure there's code to handle that.

Note: See TracTickets for help on using tickets.