Opened 4 years ago

Closed 4 years ago

#18696 closed defect (duplicate)

Portlet - DND Error in IE.

Reported by: newan Owned by: dante
Priority: undecided Milestone: tbd
Component: DojoX Widgets Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

I attached an example for a portlet within a Bordercontainer (For the use with IE it has to be delivered by a webserver). In Firefox and Chrome the DND-Event works as it should:

  • Click on the portlet an keep the Mousebutton pressed to move the portlet around.
  • Release the Musebutton to drop the portlet at that place.

IE (version 11) shows a strange behaviour:

  • the portlet sticks to the cursor even after releasing the the mousebutton.
  • I need to click again to drop the portlet

With Dojo < 1.8 it does work within IE without any issues.

Change History (2)

comment:1 Changed 4 years ago by bill

You forgot the attachment. Likely though the issue is that the portlet code needs to use dojo/touch instead of using mouse events directly.

comment:2 Changed 4 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18697.

Note: See TracTickets for help on using tickets.