Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18693 closed defect (invalid)

naming an input field on a form with a '.' as part of the name

Reported by: nhardy Owned by: nhardy
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.8.1
Keywords: Cc:
Blocked By: Blocking:

Description

The HTML spec allows for '.' to be a part of naming input fields in a form. However, when setting the value on a form, lang.getObject is called (_FormMixin._setValueAttr line 116 in 1.8.1) as opposed to obj[name] and the inputs are not set with the appropriate values.

Change History (4)

comment:1 Changed 4 years ago by bill

Owner: set to nhardy
Status: newpending

I'm not sure what you mean by "setting the value on a form".

Please attach a test case using the "attach file" button. It should be as small as possible to still reproduce the problem, almost always a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Then, give exact instructions on how to reproduce the problem using your attached test file, including the browser and version to use.

The test case is necessary both to confirm that there's a bug, and for us to be able to debug the problem.

Alternately, you can give instructions on how to reproduce the problem with an existing test case (in the tests/ directory).

Thanks!

comment:2 Changed 4 years ago by dylan

I'm surprised this is an issue, as we do something like this pretty regularly. Also would help to test against newer versions of Dojo (either 1.10.4 or 1.8.10)

comment:3 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 4 years ago by bill

Also, note that https://github.com/dojo/dijit/blob/master/tests/form/Form.html#L691 does test for input fields with dots in their name (and the test runs without errors).

Note: See TracTickets for help on using tickets.