Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18684 closed defect (fixed)

Android - FixedSplitter : problem of adaptation of sizes when turning the device

Reported by: harbalk Owned by: Patrick Ruzand
Priority: undecided Milestone: 1.9.8
Component: DojoX Mobile Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

There are problems of adaptation of relative sizes when turning the device on Android. No problem at first load regardless the device is vertical or horizontal.

Change History (7)

comment:1 Changed 4 years ago by harbalk

More precisions : The problem occurs when there are two FixedSplitter? with different orientations.

The test contains one FixedSplitter? vertical (100% width and height) that contains a 20% height Pane and another FixedSplitter? horizontal (100% width and height) that contains a 20% width Pane and another Pane that complete the page.

On Chrome : Only the first Pane adapts his relative size when turning the screen. The second one keep his size, but the third complete well the new page horizontally.

On Cordova : Same as chrome except for the third Pane which keep his size from the previous orientation.

comment:2 Changed 4 years ago by harbalk

The problem is due to the offset which is set in px and not in percent. The Pane adapts well his size but the beginning of the others panes isn't set right and there is a blank or a superposition whether the offset is to high or to small.

comment:3 Changed 4 years ago by harbalk

Finally it was the resize function which wasn't called dynamically because FixedSplitter? didn't use dojox/mobile/common.js Made a PR -> https://github.com/dojo/dojox/pull/186

comment:4 Changed 4 years ago by Adrian Vasiliu <vasiliu@…>

Resolution: fixed
Status: newclosed

In 067dea9eb71ba95c577db9c6ceb64c0545ff39a0/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 4 years ago by Adrian Vasiliu <vasiliu@…>

In c08bc0a8732d5544f34560f32db64e6e6c7158e7/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 4 years ago by Adrian Vasiliu <vasiliu@…>

In 76d5a5fd04c85ef5a87b92b4cca7c3a63cef57fd/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 4 years ago by bill

Milestone: tbd1.9.8
Note: See TracTickets for help on using tickets.