Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18680 closed defect (wontfix)

No realtime TextBox maxLength enforcement on Chrome with Android 5+

Reported by: Sebastien Brunot Owned by: Adrian Vasiliu
Priority: undecided Milestone: 1.10.4
Component: DojoX Mobile Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

I'm using the test page test_FormControls.html on Android M (Chrome browser)

In the TextBox? that accept a max of 9 characters, you can enter more than 9 characters. When you leave the text box or close the keyboard, then input string is trimmed to the first 9 characters. (AV: reproducible also with Android 5.1, but not with Android 4.2.2, iOS 8 or latest Chrome/Win?). Holds when typing letters, not when typing numbers. The code involved is in dijit/form)

Change History (7)

comment:1 Changed 4 years ago by Adrian Vasiliu

Reproducible also with Android 6 preview / Nexus 5 and Android 5.0.1 / Nexus 9.

Now, this has nothing to do with Dojo, dijit, dojox/mobile. Dijit's maxLength on TextBox? relies on the maxlength property of the standard HTML input element. And the same issue can be reproduced in pure HTML...

The bottom line: "the rationale is that maxlength is a final maximum allowed length but the act of composition can have intermediate lengths longer than the final one. To limit the entry of characters during entry would break cases where this "shrinkage" happens around the maxlength boundary." (https://code.google.com/p/chromium/issues/detail?id=400051 )

We may agree or disagree with Chrome, and for sure it's a mess that different browsers deal with it differently, but for now this is how it is.

I close the issue as a browser issue.

comment:2 Changed 4 years ago by Adrian Vasiliu

Owner: changed from Patrick Ruzand to Adrian Vasiliu
Status: newassigned

comment:3 Changed 4 years ago by Adrian Vasiliu

Resolution: wontfix
Status: assignedclosed

comment:4 Changed 4 years ago by Adrian Vasiliu

(we could close it as "invalid" instead of "won't" fix, because the current behavior is the one expected... by Chrome on Android).

comment:5 Changed 4 years ago by Adrian Vasiliu

Summary: No realtime TextBox constraint enforcement on Android M (Chrome browser)No realtime TextBox constraint enforcement on Chrome with Android 5+

comment:6 Changed 4 years ago by Adrian Vasiliu

Summary: No realtime TextBox constraint enforcement on Chrome with Android 5+No realtime TextBox maxLength enforcement on Chrome with Android 5+

comment:7 Changed 4 years ago by Adrian Vasiliu

Milestone: tbd1.10.4
Note: See TracTickets for help on using tickets.