Opened 4 years ago

Closed 4 years ago

#18678 closed defect (duplicate)

ComboBox problems

Reported by: pacofa Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

The dijit/form/ComboBox appears to be working properly on my PC in IE, Firefox and Chrome. But on Andrioid and IOS devices, it seems to be having a lot of problems.

When typing in the combobox, the list appears (most of the time) to be one letter behind the user, not recognizing the user's last keystroke, making it very difficult to properly go to and select the desired list item. It appears to select the 1st entry in the one-letter-behind-version of what you've typed, within the selection anchors (inside the combobox), then when you try correcting it by typing the correct letter over the selection anchor's entry, it does not recognize your keystroke.

The combobox also does not display a scroll bar, and the list is showing above rather than below the combobox.

Change History (1)

comment:1 Changed 4 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18501.
The one-letter-behind problem is the same root cause as #18501. About the scrollbar... iOS does not display scrollbars, but you can still scroll. If you are having a problem scrolling, that's presumably already been fixed too, see #18027.

Note: See TracTickets for help on using tickets.