Opened 13 years ago

Closed 12 years ago

#1867 closed defect (fixed)

Content/link panes in tab container preloads even on preload=false

Reported by: a_k_mittal@… Owned by: koranteng
Priority: high Milestone: 0.9
Component: Dijit Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

All remotely loaded content/link panes in a tab container download their content even if preload is set to false (default). Now the only way to delay loading is to set preload=false, AND explicitly hide all non-selected tabs at construction (style="display:none"). I think this should just be controlled by the preload property of content/link panes.

Change History (4)

comment:1 Changed 13 years ago by bill

Milestone: 0.7

Right, this is a duplicate of #1573 and (at least for now) you just need to set display: none. The problem is that the ContentPane? doesn't know that it's a TabContainer? child (and being hidden) until after it finishes initializing.

comment:2 Changed 13 years ago by dylan

Milestone: 0.70.6

Milestone 0.7 deleted

comment:3 Changed 12 years ago by bill

Component: WidgetsDijit
Owner: changed from bill to koranteng

I think with the new startup()/layout() architecture, this can work if we just do the load when layout() is called, rather than in postCreate(). I don't really want to support a preload option; maybe it's best just to never preload.

comment:4 Changed 12 years ago by bill

Milestone: 1.00.9
Resolution: fixed
Status: newclosed

OK, after Fredrik's fixes to ContentPane? this is working.

Note: See TracTickets for help on using tickets.