Opened 4 years ago

Closed 4 years ago

#18656 closed defect (invalid)

dojo.date.locale.format has a memory leak

Reported by: bschlangen Owned by: bschlangen
Priority: high Milestone: 1.12
Component: Date Version: 1.2.0
Keywords: Cc:
Blocked By: Blocking:

Description

Each time that dojo/date/local.js format() function is called memory is allocated and a portion of that memory is never garbage collected.

Tested in Chrome v. 44

Initial Digging suggests that leak is actually caused by the line:

if(pattern){str.push(_processPattern(pattern, sauce));}

Change History (4)

comment:1 Changed 4 years ago by dylan

Milestone: tbd1.11
Owner: changed from Adam Peller to dylan
Status: newassigned

comment:2 Changed 4 years ago by dylan

Priority: undecidedhigh

comment:3 Changed 4 years ago by dylan

Milestone: 1.111.12
Owner: changed from dylan to bschlangen
Status: assignedpending

Discussed this with peller today. We need a more involved test case to track this down, as we're not seeing the issue with the test cases that are built in.

@bschlangen, can you provide a more detailed test case please?

comment:4 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.