Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18647 closed defect (invalid)

_WidgetBase does not has _focusMixin and the documentation says it has it.

Reported by: francjpd Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

The Documentation says that we all should extends our widgets from _WidgetBase since it should have all the behaviour from _Widget but by looking at the code of these two classes, the _WidgetBase does not have the _focusMixin.

https://github.com/dojo/dijit/blob/master/_WidgetBase.js https://github.com/dojo/dijit/blob/master/_Widget.js

More information, Under the _Widget AND_WidgetBase API:

onBlur() Defined by: dijit/_FocusMixin Called when the widget stops being "active" because focus moved to something outside of it, or the user clicked somewhere outside of it, or the widget was hidden.

Attachments (1)

apidoc.gif (23.5 KB) - added by bill 4 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 4 years ago by bill

Resolution: invalid
Status: newclosed

_WidgetBase ... should have all the behaviour from _Widget

Huh? The whole point of _WidgetBase is to be leaner (with less functionality) than _Widget.

the _WidgetBase does not have the _focusMixin.

Yes, that's true, and it's by design.

More information, Under the _Widget AND_WidgetBase API:

onBlur()

Defined by: dijit/_FocusMixin

Yes, as it says, onBlur() is defined by dijit/_FocusMixin, not by _WidgetBase. I know it's a bit confusing, since onBlur() is listed on the page for WidgetBase, but if you hover over that icon it does say that _FocusMixin needs to be required():

Last edited 4 years ago by bill (previous) (diff)

Changed 4 years ago by bill

Attachment: apidoc.gif added

comment:2 Changed 4 years ago by francjpd

Hello,

I did not know i had to roll over to obtain such an usefull information. i apologize for the ignorance.

Best regards.

comment:3 Changed 4 years ago by dylan

I don't think it's ignorance, just not very obvious if you don't know the full history of it all.

That said, for general usage questions, you might want to start with the mailing list, http://mail.dojotoolkit.org/mailman/listinfo/dojo-interest , where we're happy to answer questions.

Note: See TracTickets for help on using tickets.