Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#18645 closed defect (worksforme)

dojo/touch broken on chrome beta

Reported by: Ognian Owned by: Kris Zyp
Priority: undecided Milestone: 1.11
Component: Events Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hello, How to reproduce: Use chrome canary i.e latest 46.0.2457.0 go to: https://dojotoolkit.org/documentation/tutorials/1.10/sliders/demos/simple.html sliders can't be drag by mouse (keyboard works) same for i.e. dojox.layout.ExpandoPane? -> dragging the splitter doesn't work I noticed this problems several weeks ago (several canary versions ago) and thought that it will be fixed in one of the next versions since it looks like a canary problem, but I even couldn't find a ticket about this... Could you please check? Thanks Ognian

Change History (10)

comment:1 Changed 4 years ago by bill

Component: GeneralEvents
Owner: set to Kris Zyp

I looked into this, and the problem is with Chrome: they've started but not finished implementing support for pointer events. Note that last year they said they wouldn't support pointer events at all, but they've since changed their mind.

Specifically. the problem is that the feature test

"onpointerdown" in document.body

is returning true (on chrome canary), as though it's supporting pointer events, but it really isn't yet.

Note: the failure reproduces on dijit/tests/form/test_Slider.html and also on tests/dnd/test_moveable.html.

If chrome is released production with this problem, I guess we will have to improve the feature test, or put in a browser sniff, so that it doesn't try to use pointer events there.

comment:2 Changed 4 years ago by bill

#18655 is a duplicate of this ticket.

comment:3 Changed 4 years ago by bill

#18659 is a duplicate of this ticket.

comment:4 Changed 4 years ago by bill

Summary: Slider and other "draggable" not working on chrome canary since several versionsdojo/touch broken on chrome canary since several versions

comment:5 Changed 4 years ago by BenCatlin

I'm seeing this in Chrome 45 beta too now that is available - but it looks like it might be related to this chrome/chromium bug: https://code.google.com/p/chromium/issues/detail?id=516050 where the pointer events are supposed to be hidden behind a flag, but aren't for some reason. It is listed as a blocking bug for 45 release.

comment:6 Changed 4 years ago by bill

Summary: dojo/touch broken on chrome canary since several versionsdojo/touch broken on chrome beta

Cool, I had meant to file a ticket against Chrome. Glad someone beat me to it. Hopefully they will fix the bug and we don't have to workaround in our code.

comment:7 Changed 4 years ago by dylan

Milestone: tbd1.11
Resolution: worksforme
Status: newclosed

Looks fixed in Chrome Canary based on https://code.google.com/p/chromium/issues/detail?id=516050

Please verify if things are fixed in your tests.

comment:8 Changed 4 years ago by Ognian

works for me too, Thanks Ognian

comment:9 Changed 3 years ago by benw84

The latest chrome beta or canary has caused a re-occurrence in this issue for me, anyone else?

comment:10 Changed 3 years ago by bill

https://dojotoolkit.org/documentation/tutorials/1.10/sliders/demos/simple.html is working fine for me on Chrome Canary mac (Version 57.0.2938.0 canary (64-bit)).

Note: See TracTickets for help on using tickets.