Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18621 closed defect (fixed)

onclick event is not firing for anchor tag within popup - IOS 8.3

Reported by: srikanth_desu Owned by: bill
Priority: undecided Milestone: 1.10.5
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Hi,

We have upgraded dojo version from 1.7.3 to 1.10.4 in our application.After upgrade anchor tag with in DropDownButton? is not firing onclick event in IOS 8.3

Note:

  1. Anchor tag is working fine without DropDownButton? code in my template file
  2. The below code is working fine with Dojo 1.7.3 in IOS 8.3
<div>
    <div dojoType="dijit.form.DropDownButton">

        <span>Example</span>
        <div dojoType="dijit.TooltipDialog">              
               <a href="#" dojoattachevent="onclick: somefunction" onclick="return false;">Click me</a>               
        </div>

    </div>
</div>

Attachments (1)

example.htm (944 bytes) - added by srikanth_desu 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by bill

Owner: changed from bill to srikanth_desu
Status: newpending

I don't understand your example. You can't have a dojoattachevent except inside of templates. And, what did you expect to happen vs. what actually happened?

comment:2 Changed 4 years ago by bill

PS: please attach a test case using the "attach file" button, a single HTML file that we can load in the browser (i.e. not PHP, JSP, etc.).

Changed 4 years ago by srikanth_desu

Attachment: example.htm added

comment:3 Changed 4 years ago by srikanth_desu

Status: pendingnew

Attachment (example.htm) added by ticket reporter.

comment:4 in reply to:  1 Changed 4 years ago by srikanth_desu

Replying to bill:

I don't understand your example. You can't have a dojoattachevent except inside of templates. And, what did you expect to happen vs. what actually happened?

Please find the attached working htm file(example.htm).

This file contains a hyperlink - Link1 and a dijit/DropdownButton which in turn contains another hyperlink - Link2 inside a TooltipDialog?.

Clicking on both the hyperlinks need to provide an alert with corresponding messages.

in iOS8.3 : Clicking on Link1, which is outside DropdownButton?, works fine by providing alert message.

But clicking on Link2, which is inside DropdownButton?, doesn't work. I need to show the alert message when I click on that Link2, but it didn't show. It remains unresponsive.

in iOS 7.1: Clicking on Link1, which is outside DropdownButton?, works fine by providing alert message.

But clicking on Link2, which is inside DropdownButton?, doesn't work for the first time but works fine for the 2nd time.

The above failed cases in IOS are working fine with Dojo version 1.7.3 but not with Dojo 1.10.4

comment:5 Changed 4 years ago by bill

Ah OK thanks. I reproduce the problem on 1.10.4, but it's fixed in master, thanks to d4b8283c5c1cff9397290438165bb57a77a974de.

I guess that since this is a regression I should backport that change to 1.10.

I checked and 1.9 and 1.8 are working fine.

Last edited 4 years ago by bill (previous) (diff)

comment:6 Changed 4 years ago by bill

Milestone: tbd1.10.5
Owner: changed from srikanth_desu to bill
Status: newassigned
Summary: onclick event is not firing for anchor tag with in DropDownButton - IOS 8.3onclick event is not firing for anchor tag within popup - IOS 8.3

comment:7 Changed 4 years ago by bill

Resolution: fixed
Status: assignedclosed

I backported the fix to the 1.10 branch in cfbb049eac4c89faa5e72ad7121d6f0634585071.

comment:8 Changed 4 years ago by bill

#18632 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.