Opened 4 years ago

Closed 4 years ago

#18620 closed defect (fixed)

Multiselect on Mac in dojox/Calendar

Reported by: inanutshellus Owned by: Adam Peller
Priority: undecided Milestone: 1.11
Component: Dojox Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Any widget using Selection.js (such as dojox/Calendar) is only able to multi-select if you control-click, even on OSX. (Unfortunately for them, control-click also simulates the Windows right-click behavior, making the browser context menu appear. OSX users expect to use command/meta-click.)

Demonstrable on OSX by switching the calendar selection mode to "multiple" and trying to control- or command-click multiple items here: http://demos.dojotoolkit.org/dojox/calendar/tests/columnview.html

Change History (2)

comment:1 Changed 4 years ago by inanutshellus

Supplied a patch here:

https://github.com/dojo/dojox/pull/181

As I mentioned in the pull request, this is a duplicate of https://bugs.dojotoolkit.org/ticket/17664, which was only applied to the "2.0/delite" branch. You may want to backport cjolif's patch to the 1.0 branch, or apply my patch. His patch seems to contain multiple changes whilst mine only fixes the right-click issue for OSX users.

Last edited 4 years ago by inanutshellus (previous) (diff)

comment:2 Changed 4 years ago by bill

Milestone: tbd1.11
Resolution: fixed
Status: newclosed

Fixed in f3ac2a540af3a0f96c56d2073a03a71056b79fc1.

Note: See TracTickets for help on using tickets.