Opened 4 years ago

Closed 4 years ago

#18610 closed defect (invalid)

Issue With respect to PlaceHolder attribute

Reported by: saravanakumarmay06 Owned by: saravanakumarmay06
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Team ,

I'm able to replicate my issue with IE9 Compatibility with Quirks mode.

I'm creating textbox with some placeholder attribute. When i'm clicking the textbox over the placeholder , my foucus is not applied to that textbox. But when i'm clicking the textbox other than placeholder place, my foucus is applied to that textbox.

Is it possible to apply the focus even when i'm clicking the textbox over the placeholder??

Simple code

HTML

<div id = "root">

JS

new dijit.form.TextBox?({placeHolder : "Your Text Here"}).placeAt(dojo.byId("root"))

Change History (5)

comment:1 Changed 4 years ago by dylan

Why are you using quirks mode? What browser version exactly is the issue occurring in? We strongly advocate against using quirks mode in general, as this often removes features and is never exactly the same as the old browser you're trying to mimic.

comment:2 Changed 4 years ago by bill

Component: GeneralDijit - Form
Owner: set to saravanakumarmay06
Status: newpending

Also, did you really see this problem on dojo 1.10.4? It's working for me, as tested with test_validate.html, using both IE9 and IE10. How about you?

comment:3 Changed 4 years ago by saravanakumarmay06

Status: pendingnew

Team when i'm working with this issue , i got the fix

My Code

var Widget= dojo.query(".dijitPlaceHolder")

Widget.forEach(function(MyContol?) {

MyContol?.setAttribute("UNSELECTABLE", "on")

});

comment:4 Changed 4 years ago by bill

Status: newpending

OK, glad you found a solution. It seems like a reasonable change, but as I said above, I can't reproduce your problem. If you have a test case that fails please attach it using the "attach file" button. Otherwise I'll close this as "works for me", since it does.

comment:5 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.