Opened 5 years ago

Closed 5 years ago

#18578 closed defect (duplicate)

onclick of Button not triggered when using ComboBox in IE 10 or higher

Reported by: robert.E Owned by:
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.10.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi, I have a page (see attached file) containing a dijit.form.ComboBox? and a standard button. When I select a new value in the combobox via mouse and then immediately click on the button the onclick action of the button will not be triggered. But when I wait some time (1 or 2 seconds) before clicking on the button the onclick action will be triggered - so it seems to be a timing issue.

That problem is reproducable only in IE 10 or higher. I tried it with dojo 1.10.2, 1.10.3 and 1.10.4 and all those dojo versions have that bug.

regards, Robert.

Attachments (1)

test.html (999 bytes) - added by robert.E 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by robert.E

Attachment: test.html added

comment:1 Changed 5 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18479.
This is essentially a duplicate, because the real issue is about clicking a native control <1000ms after clicking something with dojoClick=true. And it's an issue with dojo/touch, not dijit per se.

Note: See TracTickets for help on using tickets.