Opened 4 years ago

Closed 4 years ago

#18571 closed defect (duplicate)

Loss event when using dijit/Tree with DnD on IE

Reported by: tsofist Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

The defect can be seen on the test: dijit/tests/tree/test_Tree_DnD.html Add the following code:

Code:

  require([
      "dojo/on",
      "dojo/domReady!"
  ], function (on) {
      on(document.body || document.getElementsByTagName("body")[0], "click", function () {
          console.log("clicked!");
      });
  });

Now open any version of IE (except IE9, if trust emulation mode) and click on item of the tree id="collectionsTree" (one that in paragraph Collection Count Summary), immediately after that click on the body. And looking at the console, we note that the first click is lost, while next events fired normal.

Change History (3)

comment:1 Changed 4 years ago by bill

Sounds like a duplicate of #18362. Clicking <body> works after waiting 1 second?

comment:2 in reply to:  1 Changed 4 years ago by tsofist

Replying to bill:

Sounds like a duplicate of #18362. Clicking <body> works after waiting 1 second?

Yes, it is. Thank you, bill! Is there any progress in this direction? So far, I have to use a patch from "reiprecht" (from #18362)

Forgive forgiveness did not find such references.

comment:3 Changed 4 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18362.
Probably you saw already, #18362 is fixed.

Note: See TracTickets for help on using tickets.