Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1857 closed defect (invalid)

Slider onClick shouldn't notify listeners

Reported by: guest Owned by: Douglas Hays
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: slider onclick Cc:
Blocked By: Blocking:

Description

slider.js line: 636

set the position of the handle _onClick: function(/*Event*/ evt){

at last line you call this.notifyListeners();

so you fire a onvaluechanged event when the user clicks on the drag handle. but it should only fire when the left mosue button is released i think comment out this line please

Change History (3)

comment:1 Changed 13 years ago by Douglas Hays

Owner: changed from bill to Douglas Hays

comment:2 Changed 13 years ago by Douglas Hays

Resolution: invalid
Status: newclosed

Currently the slider value changes onmousedown, so it makes sense to send the notification since the slider handle has moved. When you click over the handle, its possible that the handle may move a tiny amount, so the notification is sent. I need to better understand what problems are being caused by the notifications in order to design a good solution that doesn't break other users. Please reopen this if there is additional info that can be added to the problem description, and please add an email contact.

comment:3 Changed 13 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.