Opened 4 years ago

Closed 4 years ago

#18569 closed defect (invalid)

dojo 1.8: Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus.

Reported by: devkanthjijj Owned by: devkanthjijj
Priority: undecided Milestone: 1.13
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

hi, Im using dojo 1.8 in my project, and have dGrid and gridx implementations across the board. But, I still have a problem with focus not being visible in dojo Menu.js library in IE8.

I have a tree implementation and each row in the tree, on right click opens a menu with menu items. On right click, the first time, appears to have no issue, if we move to another row and right click on that, I have the focus issue mentioned above.

Here is where the exception occurs in dojo library:

function _30(){ if(_2c.refocus&&_2f){ _2f.focus(); <------------Exception thrown. }

Menu.js, line 115, character 1

Please advise if there is a patch available, because I don't find any supporting material with respect to dojo 1.8 facing issues in IE8.

Code Snippet:

function buildTree(rootUUID, containerId) {
    
    if (paramTreeStore === null) {

        paramTreeStore = "not null";
        dijit.byId("terminologyTreeStandby").show();
        require(["dgrid/OnDemandList", "dgrid/OnDemandGrid",
            "dgrid/Selection", "dgrid/Keyboard",
            "dgrid/extensions/DnD",
            "dojo/dnd/Source",
            "dgrid/tree", "dojo/_base/declare",
            "dojo/store/JsonRest", "dojo/store/Observable",
            "dojo/store/Cache", "dojo/store/Memory",
            "dojo/store/util/SimpleQueryEngine",
            "dojo/domReady!", "put-selector/put",
            "dgrid/test/data/base"],
                function(OnDemandList, OnDemandGrid, Selection, Keyboard, DnD, DnDSource, tree, declare, JsonRest, Observable, Cache, Memory, SimpleQueryEngine, put) {

                    var DnDList = declare([OnDemandList, Keyboard, Selection, DnD]),
                            DnDGrid = declare([OnDemandGrid, Keyboard, Selection, DnD]);
                    testStore = window.testStore = Observable(Cache(JsonRest({
                        target: treeUrl, //serviceRoot + "/newconcept/uuid/dojoTreeRoot3?", 
                        idProperty: "uuid",
                        queryE

Attachments (1)

testcase_dojo.rtf (722 bytes) - added by devkanthjijj 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by bill

Owner: set to devkanthjijj
Status: newpending

Try to make a test case that reproduces this problem (as small a test case as possible), and attach it using the "Attach file" button. Otherwise I can't debug.

It's true that IE gets upset if you focus something that isn't yet visible, but I don't know why that's happening in your case.

Changed 4 years ago by devkanthjijj

Attachment: testcase_dojo.rtf added

comment:2 Changed 4 years ago by devkanthjijj

Status: pendingnew

Attachment (testcase_dojo.rtf) added by ticket reporter.

comment:3 Changed 4 years ago by dylan

Component: GeneralDijit

comment:4 Changed 4 years ago by bill

Status: newpending

testcase_dojo.rtf is not a test case. The test case needs to be an HTML file.

comment:5 Changed 4 years ago by dylan

Milestone: tbd1.12

comment:6 Changed 4 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.