Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#18568 closed defect (invalid)

Unable to scroll in Dialog or scroll page when voice over enabled.

Reported by: shivanuj Owned by: Patrick Ruzand
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.10.0
Keywords: Cc:
Blocked By: Blocking:

Description

Environment - iPhone 5s, iOS8.2, Voice Over, Safari Steps to reproduce. 1. Create any page with Dialog or ScrollPane?

Note : For dialog, content should be large enough to generate a scrollable area

2. Enable Voice over in iPhone 3. Launch page created in step 1. 4. Tap once anywhere in Dialog or ScrollPage? content area to set focus 5. Double tap with three fingers on Dialog or ScrollPage? content area, do not release on second tap and swipe three finger up or down to scroll. This does not work 6. If you close dialog or scrollpane and try to do same on any page with page scroll present, step 4 and 5 works well 7. If you swipe with single finger down, focus moves from last focusable element in visible area of dialog or scroll to the browser buttons. It does not go to non-visible area which is present below side in content area.

Change History (3)

comment:1 Changed 5 years ago by bill

Owner: changed from mikeb to Patrick Ruzand
Status: newassigned

Patrick, probably this should go to someone on your team?

comment:2 Changed 5 years ago by Patrick Ruzand

Component: AccessibilityDojoX Mobile
Resolution: invalid
Status: assignedclosed

Three-fingers gesture is not supported by Dojo mobile scrollable widgets as this is a feature that comes with native scroll, and dojox/mobile uses a js scroll mechanism, and does not re-implement this gesture.

However, you should be able to scroll the view via a double-tap and hold your finger on the screen until you hear three rising tones, then while your finger remains on the screen, swipe up or down to scroll the ScrollableView? up or down.

comment:3 Changed 4 years ago by shivanuj

Patrik,

Thanks for answering this. Could you tell me exactly where this logic is handled due to which, on double-tap and hold it becomes available for scrolling. I mean file and line number. I may want to enable same on three finger tap and hold.

Note: See TracTickets for help on using tickets.