Opened 4 years ago

Closed 4 years ago

#18567 closed defect (duplicate)

dojox/fx/ext-dojo/complex no longer works for rgba

Reported by: rjh Owned by: Bryan Forbes
Priority: undecided Milestone: tbd
Component: fx Version: 1.9.7
Keywords: Cc:
Blocked By: Blocking:

Description

I believe originally the complex extension for dojo fx was modified here to support changing rgba backgrounds. Since then I feel as if the format of the property object has changed quite a bit. Below is the relevant code from the complex extension:

if(start instanceof dojo.Color){
  ret[p] = dojo.blendColors(start, prop.end, r, prop.tempColor).toCss();
}else if(start instanceof dojox.fx._Complex){
  ret[p] = start.getValue(r);
}else if(!dojo.isArray(start)){
  ret[p] = ((prop.end - start) * r) + start + (p != "opacity" ? prop.units || "px" : 0);
}

the start attribute in properties is no longer an instance of dojo.Color but rather of dojox.fx._Complex, while the end attribute remains an instance of dojo.Color. Also the original patch that returns a css with alpha ".toCss(true)" has now been reverted back to ".toCss()" which ignores alpha.

Change History (1)

comment:1 Changed 4 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18566.

Note: See TracTickets for help on using tickets.