Opened 4 years ago

Closed 4 years ago

#18532 closed defect (duplicate)

has("ie") returns undefined on desktop IE11 and Windows Phone 8.1

Reported by: Youcef Mammar Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Desktop IE11 user agent string: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Windows Phone 8.1 user agent String: Mozilla/5.0 (Mobile; Windows Phone 8.1; Android 4.0; ARM; Trident/7.0; Touch; rv:11.0; IEMobile/11.0; NOKIA; Lumia 720) like iPhone OS 7_0_3 Mac OS X AppleWebKit/537 (KHTML, like Gecko) Mobile Safari/537

As you can see, theses strings no longer contain MSIE string on which sniff is based.

Change History (1)

comment:1 Changed 4 years ago by ben hockey

Resolution: duplicate
Status: newclosed

Duplicate of #18443.

Note: See TracTickets for help on using tickets.