Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#18531 closed defect (invalid)

Can not have single quote mark as placeholder text in management/common/SimpleFilter

Reported by: steven-zou Owned by: steven-zou
Priority: undecided Milestone: tbd
Component: General Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

hi devs,  We are using the SimpleFilter? barTop: [

[{

pluginClass: SimpleFilter?, searchBoxPlaceHolder: this.nls.gridSerachText, colSpan: 2

}]

the gridsearchText is globalized, so if the gridSerachText is in Frech, it might have single quote mark in the text. eg: gridSerachText: "Recherche des noms d'objet de journal..." Which cause the SimpleFilter? input box failed to render. Any ideas?

Resubmit for #18421 since it's closed and I can not open it cauz I'm not the owner of #18421.

Change History (7)

comment:1 Changed 5 years ago by bill

Owner: set to steven-zou
Status: newpending

Please specify which grid widget you are using.

comment:2 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 Changed 5 years ago by bill

#18588 is a duplicate of this ticket.

comment:4 in reply to:  1 Changed 5 years ago by liujulingbj

Replying to bill:

Please specify which grid widget you are using.

The widget id we're using is dijit.form.textbox. Please help to reopen the defect.

comment:5 Changed 5 years ago by bill

But, the question was: what grid widget are you using? You mentioned management/common/SimpleFilter and gridsearchText, so it sounds like you are talking about a problem either with dgrid or gridx, or maybe EnhancedGrid?.

comment:6 in reply to:  5 Changed 4 years ago by liujulingbj

Replying to bill:

But, the question was: what grid widget are you using? You mentioned management/common/SimpleFilter and gridsearchText, so it sounds like you are talking about a problem either with dgrid or gridx, or maybe EnhancedGrid?.

"gridx/modules/Filter", "gridx/support/QuickFilter"

comment:7 Changed 4 years ago by bill

OK. In that case you should file a ticket at https://github.com/oria/gridx/issues.

Note: See TracTickets for help on using tickets.