Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18527 closed defect (duplicate)

Wrong Internet Explorer click event in dijit.tree with popup dijit.Menu

Reported by: mvillafranca Owned by: bill
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Dear Dojo team, i have found what i suspect is a bug:

If you create a dijit.Tree (the data source seems irrelevant from my tests)

Then create a dijit.Menu and associate it to the tree, so that it will come up on right clicks.

Then register a click listener on the tree, so that some action will be performed when the user left-clicks the tree.

In chrome and FF (current versions), the click handler will be triggered on left clicks, and the menu will come up on right clicks (correct)

In Explorer (at least in IE 11), the click handler is triggered on left clicks. The right click, however, brings up the context menu and triggers the click handler, reporting a left click.

I know it's confusing, code to reproduce here: https://jsfiddle.net/ujx74a4r/

Attachments (1)

tree_menu.html (2.9 KB) - added by bill 4 years ago.
standalone version of test case

Download all attachments as: .zip

Change History (3)

comment:1 Changed 4 years ago by mvillafranca

Update: I have verified that this does not happen when you activate IE9 emulation mode in IE11. It does happen in Edge and IE10 mode

comment:2 Changed 4 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #18342.
Already fixed if you get the latest version of dojo core, see #18342.

Version 0, edited 4 years ago by bill (next)

Changed 4 years ago by bill

Attachment: tree_menu.html added

standalone version of test case

Note: See TracTickets for help on using tickets.