Opened 5 years ago

Closed 5 years ago

#18514 closed defect (duplicate)

Shrinksafe fails to shrink angular (tested with 1.3.6)

Reported by: BenjaminH Owned by: Richard Backhouse
Priority: undecided Milestone: tbd
Component: ShrinkSafe Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

Here is the simplified case:

The following input code

define([], function () {
this.testAttribute = function /***/problematicFunction/***/(name, directiveFactory) {
     var testFunction = function() {
         //doAnything 
      };
      testFunction(/***/problematicFunction/***/);
      return this;
  };
});

becomes

define("desktop/shrinkSafeTest",[],function(){
this.testAttribute=function /***/problematicFunction/***/(_1,_2){
var _3=function(){
};
_3(/***/_4/***/);
return this;
};
});

Change History (2)

comment:1 Changed 5 years ago by BenjaminH

What I forgot to mention: in AngularJS, the problematic function is registerDirective.

comment:2 Changed 5 years ago by ben hockey

Resolution: duplicate
Status: newclosed

Duplicate of #11673.

Note: See TracTickets for help on using tickets.