Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18511 closed defect (fixed)

[patch] dijit/popup: sticky vertical scrollbar

Reported by: Jason Cowley Owned by: bill
Priority: undecided Milestone: 1.9.8
Component: Dijit Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

This occurs in all versions of IE.

  1. Open the attached test page in IE. The page consists of a dijit/form/FilteringSelect widget.
  2. Make sure you have a "tall" browser window and click the drop-down button to display the full list of items. You should not see a vertical scroll bar. Close the drop-down.
  3. Shrink the browser window so that the full list of items can't be displayed and click the drop-down. You should see the list of items with a vertical scrollbar. Close the drop-down.
  4. Grow the browser window so the full list of items should fit again and click the drop-down.

Expected: Full list of items displayed with no vertical scroll bar Actual: Full list of items display with vertical scroll bar

Does not happen on other browsers.

Will attach test page and patch.

Attachments (2)

test.html (2.1 KB) - added by Jason Cowley 4 years ago.
Test page to reproduce bug
MOD-875-JC.patch (638 bytes) - added by Jason Cowley 4 years ago.
Patch file to fix issue

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Jason Cowley

Attachment: test.html added

Test page to reproduce bug

Changed 4 years ago by Jason Cowley

Attachment: MOD-875-JC.patch added

Patch file to fix issue

comment:1 Changed 4 years ago by dylan

Milestone: tbd1.11
Summary: dijit/popup: sticky vertical scrollbar[patch] dijit/popup: sticky vertical scrollbar

Looks like a simple fix, may want to consider for 1.11.

comment:2 Changed 4 years ago by dylan

@bill, want to consider this one? It has a test and a one line patch (to set overflow-y). The patch itself is trivial so it can probably be accepted without a CLA, though I'll ask for one.

@jcowley, can you file a CLA when you get a chance? http://dojofoundation.org/about/claForm

comment:3 Changed 4 years ago by bill

Milestone: 1.111.9.8
Status: newassigned

Thanks for the fix. Sure, I'll check this in, and backport. Looks like setting overflow is unnecessary. Since open() sets overflowY, hide() should do the same.

Note that there's no automated test because it's too hard to change the viewport size from doh/robot (or for that matter from webdriver).

comment:4 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 1ab27cefdce2ddd2f386dcfd7bba1a8dc6163cc7/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 4 years ago by Bill Keese <bill@…>

In b939f6e2167bb1d4fbb8443e58a0fea2b998868c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 4 years ago by Bill Keese <bill@…>

In a6a3ad29f49f6ce0c7bf657b6d7d4ea1ed310745/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.