Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1851 closed defect (fixed)

ComboBox/Select Arrow does not appear in FF when created programatically and used in an unselected tab

Reported by: aaronmevans@… Owned by: Douglas Hays
Priority: high Milestone:
Component: General Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

Here is the scenario:

  1. I have a widget, acme.widget.MyWidget?. It is a simple widget that programatically creates a Select sub-widget and sets its data provider's data to an array of options.
  1. I have a page that contains 2 tabs. The content of both tabs are local and identical. They both contain an instance of MyWidget?.
  1. When you load this page in FF (1.5 and 2.0), the Select arrow image appears only for the instance in the *selected* tab (tab 1), never for the unselected tab (tab 2).

Attachments (2)

tabs_with_select_test_case.zip (2.8 KB) - added by aaronmevans@… 13 years ago.
Contains files for a reproducible test case. Check the README.txt.
1851.patch (675 bytes) - added by Douglas Hays 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by aaronmevans@…

Contains files for a reproducible test case. Check the README.txt.

comment:1 Changed 13 years ago by bill

Milestone: 0.5
Owner: changed from anonymous to Douglas Hays

This may be a duplicate bug.

comment:2 Changed 13 years ago by aaronmevans@…

Is there any work-around? This wasn't a problem in 0.3 and I am trying to upgrade but this problem is a bit of a show-stopper.

comment:3 Changed 13 years ago by Douglas Hays

Milestone: 0.50.4.1

Changed 13 years ago by Douglas Hays

Attachment: 1851.patch added

comment:4 Changed 13 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [6455]) Fixes #1851

comment:5 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.