Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#18507 closed defect (fixed)

[regression] Dijit/Menu left click to open not opening menu with space key

Reported by: nicthemighty Owned by: bill
Priority: undecided Milestone: 1.10.5
Component: Dijit Version: 1.8.3
Keywords: Cc:
Blocked By: Blocking:

Description

Dijit/Menu? line 187, part of bindDomNode().

on(cn, delegatedEvent("keydown"), function(evt){
    if(evt.keyCode == 93 || // context menu key
    (evt.shiftKey && evt.keyCode == keys.F10) || // shift-F10
    (this.leftClickToOpen && evt.keyCode == keys.SPACE) // space key
)

When I press space to signal a left click, this is set to the DOM node that the event was fired from, so leftClickToOpen is false. I can still use shift + F10, but looks like an error in the left click code.

Change History (5)

comment:1 Changed 5 years ago by bill

See also related #17219.

comment:2 Changed 4 years ago by bill

Milestone: tbd1.11
Status: newassigned

Good catch, and this is also undefined in the click/contextmenu handler above. The bad code came from https://github.com/dojo/dijit/commit/a1603906e165c51c8ff57a084fe165f409348fa4. I don't know why the regression tests aren't catching this problem though.

comment:3 Changed 4 years ago by bill

Milestone: 1.111.10.5
Summary: Dijit/Menu left click to open not opening menu with space key[regression] Dijit/Menu left click to open not opening menu with space key

I'll check in the fix plus keyboard and mouse tests for left-click context menus.

comment:4 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 5f7b1cf77f98e4c981430f6dd487a845dc8a013c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 4 years ago by Bill Keese <bill@…>

In addd2ed95a2dbb612d2350866e7e1905fe77faf3/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.