Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18501 closed defect (fixed)

ValidationTextBox: error state one keystroke behind on iOS8

Reported by: bill Owned by: bill
Priority: undecided Milestone: 1.8.11
Component: Dijit - Form Version: 1.10.4
Keywords: Cc:
Blocked By: Blocking:

Description

When using Dojo version 1.10 and viewing a dijit.form.NumberTextBox? on an iPad using iOS8, the NumberTextBox? does not show validation errors on some invalid inputs.

To Reproduce the issue, using an iPad go to the following page: http://livedocs.dojotoolkit.org/dijit/form/NumberTextBox and run the first example (Declarative Example). A valid input value is between -20000 and + 20000, the initial value is 3000. Click the box and add an invalid character after the "3000" (for example "3000&"). Notice there is no validation marker. Now add another character (for example "3000&8"). Notice the validation marker now shows up.

On other (desktop) browsers, the validation error appears as soon as an invalid character is entered.

Same root cause as #18396.

Change History (27)

comment:1 Changed 4 years ago by bill

Owner: set to bill
Status: newassigned

comment:2 Changed 4 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 054073823470949ace3003f20fdb66ea5e470670/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 4 years ago by bill

Milestone: tbd1.11

Initially just checking code into master branch (for 1.11). The fix is non-trivial, so before backporting (if we want to backport), some other people should also check that the fix doesn't break anything.

comment:4 Changed 4 years ago by Bill Keese <bill@…>

In cd0c45dd50af678ca691c72fb39c090bc252bec0/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 4 years ago by Bill Keese <bill@…>

In 23efa8a77ebe85c6e1f84784450e20603a3dab61/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 4 years ago by Bill Keese <bill@…>

In 4b3b6fada5bc7135478b3bd82fefda64a9d4b727/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 4 years ago by Bill Keese <bill@…>

In 9e53ae88621047f96e0d7a4b9c93afdf262a43d8/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 4 years ago by Bill Keese <bill@…>

In 5f3313657ea0a217596882318b50bc71996bf31b/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 4 years ago by Bill Keese <bill@…>

In b52780544840461f4e9102ab080b85bf34f68154/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 4 years ago by Nick Nisi <nick@…>

In 1ade42e637f4388a8688e61c28f5f2fc6702a605/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 4 years ago by Bill Keese <bill@…>

In a18736b2d282af4666f03e33562f4ed67a86eab6/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:12 Changed 4 years ago by Bill Keese <bill@…>

In d4c4cca5aefe9f7127bd5cc15aedf01162ceba79/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:13 Changed 4 years ago by Bill Keese <bill@…>

In f0cd642fe6094150c00d65cdc12d00c3109ed723/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:14 Changed 4 years ago by Bill Keese <bill@…>

In 34dbf65145b2cf2cadbc4393242b8f44db0bd1ef/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:16 Changed 4 years ago by Bill Keese <bill@…>

In fd33733bcf103058bdb8ef53e13e5e6a41ab93ad/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:15 Changed 4 years ago by Bill Keese <bill@…>

In f684ede2687f91d2f7b78cf6eb24585a3d556349/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:16 Changed 4 years ago by Bill Keese <bill@…>

In f2ce2fc1ddc2659e3370ee148c8ad1bf0c390895/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:17 Changed 4 years ago by bill

Milestone: 1.111.8.11

comment:18 Changed 4 years ago by Bill Keese <bill@…>

In ba3a6b1ba8d405f7aecd1764406ccc6484c56537/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:19 Changed 4 years ago by Bill Keese <bill@…>

In 3b14c63360f90d8dcca30b6031c878c0acc6be68/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:20 Changed 4 years ago by Bill Keese <bill@…>

In 82e3f709617edd70951389e0a5cae1061fa01ac0/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:21 Changed 4 years ago by Bill Keese <bill@…>

In 6e4e68aefa034a1a8a1ffcf5700e580e49d8b1d8/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:22 Changed 4 years ago by Bill Keese <bill@…>

In 563129c4745338d859d4b26460b225ff0a80955c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:23 Changed 4 years ago by Bill Keese <bill@…>

In bc4a82d4d017509faededebbbdbad7c6054a25df/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:24 Changed 4 years ago by Bill Keese <bill@…>

In f3f10cc5be13c3cb2531c5cdbfe53b0fd0b55b3b/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:25 Changed 4 years ago by Bill Keese <bill@…>

In 74445e54eeb74821df470a25140bbbad248fa32c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:26 Changed 4 years ago by bill

#18678 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.